مهمان عزیز خوش‌آمدید. ورود عضــویت


حل شده استفاده از پلاگین های ceryberry
#1
سلام دوستان من تو برنامم لازم دارم که از پلاگین هایcordovaDialer,cordovaSms,cordovaDialog,cordovaWallpaper
استفاده کنم اما وقتی خروجی میگیرم و تو سایت کوکن بارگزاری میکنم قسمت پلاگین ها باید به صورت دستی وارد بشن به غیر از دیالوگ بعد از نصب وقتی کمپایل رو میزنم درنهایت ایکون اندروید قرمز میشه و خروجی نمیگیره (سه حالتش رو هم امتحان کردم)این هم متن ارور:

نقل قول:COMPILER ERROR:

Failed to fetch plugin https://github.com/PurpleMADcanada/Wallp...Gap-Plugin via git.
Either there is a connection problems, or plugin spec is incorrect:
Error: git: Command failed with exit code 1 Error output:
error: pathspec 'e8838e1a91b47093b00e669b8a5efadd3f7ddbd8.git' did not match any file(s) known to git.

CORDOVA LOG:

[2017-08-11 13:40:00.465] [DEBUG] AndroidBuilder - [prepare] cordova restore platforms
[2017-08-11 13:40:00.478] [DEBUG] AndroidBuilder - [prepare] adding engine [email protected]
Subproject Path: CordovaLib
Subproject Path: CordovaLib
Subproject Path: CordovaLib
[2017-08-11 13:40:16.229] [DEBUG] AndroidBuilder - [prepare] cordova restore plugins
[2017-08-11 13:40:16.231] [DEBUG] AndroidBuilder - [prepare] adding plugin [email protected]
[2017-08-11 13:40:16.256] [DEBUG] AndroidBuilder - [prepare] adding plugin [email protected]
[2017-08-11 13:40:16.279] [DEBUG] AndroidBuilder - [prepare] adding plugin [email protected]
[2017-08-11 13:40:16.299] [DEBUG] AndroidBuilder - [prepare] adding plugin cordova-plugin-dialogs@*
[2017-08-11 13:40:16.318] [DEBUG] AndroidBuilder - [prepare] adding plugin https://github.com/PurpleMADcanada/Wallp...7ddbd8.git
[2017-08-11 13:40:16.669] [DEBUG] AndroidBuilder - Failed to fetch plugin https://github.com/PurpleMADcanada/Wallp...Gap-Plugin via git.
Either there is a connection problems, or plugin spec is incorrect:
Error: git: Command failed with exit code 1 Error output:
error: pathspec 'e8838e1a91b47093b00e669b8a5efadd3f7ddbd8.git' did not match any file(s) known to git.

فک میکنم میگه پیدا نشد و پشتیبانی نمیکنه خروجی سایت فون گپ رو هم امتحان کردم تو اون که اصلا نمی شد پلاگین نصب کرد و خودش هم نصب نمی شد موناکا هم پشتیبانی نمیکرد(اینا در صورتی هست که قبلا برای تست یه خروجی از دیالر گرفته شده و کار میکرده توسط فرد دیگه ای تو تاپیک این افزونه ها) لطفا راهنمایی کنید چیکار کنم؟
 
پاسخ دهید
 سپاس شده توسط:
#2
میشه پاسخ بدید که برای استفاده از اینا چیکار میتونم بکنم؟ 2
 
پاسخ دهید
 سپاس شده توسط:
#3
سلام
cordovaWallpaper من استفاده کردم و مشکلی نداشت
بعد از خروجی از کاسنتراکت یه فایل  intelxdk.config.additions میده بهتون که توش پلاگین هایی که استفاده کردین رو اسم برده
از روی همونها میشه فهمید که باید چطور نصب کرد توی کوکون


مثلا اگه توی اون فایل همچین آدرسی بود
https://github.com/miladesign/pushe-cordova-plugin
میرید از قسمت کاستوم (بخش پلاگینها)این رو وارد میکنید و آخرش اینو اضافه میکنید > git.
و بعد میزنید رو اینتسال
 
پاسخ دهید
 سپاس شده توسط: ghasem ، sajjadr2001
#4
مشکل حل شد دوستان دقت کنند ادرس گیت هاب پلاگین که تو فایل intelxdk.config.additions میاد اگه به این صورت
هست:https://github.com/anemitoff/PhoneGap-PhoneDialer#0aef448287b8778d435d933037d90445ddb10133

باید در قسمت پلاگین ها>کاستوم> به این صورت ادرسشو وارد کنن:https://github.com/anemitoff/PhoneGap-PhoneDialer.git
در واقع اون هشتگ و بعدش اضافه هست موفق باشید
 
پاسخ دهید
 سپاس شده توسط: shazde ، Mehrshad Farahani ، Dr.AR
  


موضوعات مشابه ...
موضوع نویسنده پاسخ بازدید آخرین ارسال
  تغییر نوع عدد omidsha 1 21 5 ساعت قبل
آخرین ارسال: m.moradi
  مشکل در چرخش محمد 82 0 11 7 ساعت قبل
آخرین ارسال: محمد 82
  پرداخت درون برنامه ای محمد 82 2 32 8 ساعت قبل
آخرین ارسال: محمد 82
  مشکل در اسپرایت و انیمیشن محمد 82 2 27 8 ساعت قبل
آخرین ارسال: محمد 82
  حل شده ترمز در فیزیک مازیار 6 73 دیروز، 09:09 عصر
آخرین ارسال: omidsha

پرش به انجمن: