مهمان عزیز خوش‌آمدید. ورود عضــویت


نکاتی در راهنمای نصب و راه اندازی وینوس
#1
Exclamation 
سلام به همه دوستان.

اول از همه لطفا خطاهای خودتون رو اینجا نفرستید چون جوابی نمیدم بهشون. خطاهای خودتون رو توی صفحه گیت هاب وینوس ارسال کنید.

خب گویا همه روش های خروجی (خوب) گرفتن کانستراکت بسته شدن و خوشبختانه قبل از بسته شدن کوکون تونستم سورس کانواس+ اونا رو دربیارم و توی وینوس استفاده کنم.

توی این پست راهنمای نصب وینوس و ابزار اون رو کم کم و سر وقت قرار میدم.


1. NodeJs
نصب این ابزار خیلی ساده هستش. کافیه اونو از صفحه زیر دریافت کنید و با اجرای فایل نصبی اون، نصبش کنید:


برای چک کردن درست بودن نصب اون میتونید کد زیر رو توی cmd (با زدن کلیدهای پنجره + R از کیبورد و اجرای دستور cmd) اجرا کنید:
کد:
node -v

در صورتی که درست نصب شده باشه نسخه نصب شده رو نشون میده.


2. JDK
این ابزار رو میتونید از هر سایتی که بخواید دریافت و نصب کنید ولی حتما نسخه 8 (یا 1.8) اون رو متناسب با بیت ویندوز خودتون (64بیت یا 32/86 بیت) انتخاب کنید.
بعد از دریافت اون میتونید به طریقی که در لینک زیر هم به صورت متنی/عکسی هم تصویری آموزش داده شده نصب کنید.


بعد از نصب و انجام مراحل گفته شده حتما توی cmd چک کنید که درست نصب شده یا خیر.

دقت کنید همونجوری که شما توی cmd چک میکنید که ابزاری نصب هست یا نه وینوس هم همونطور چک میکنه. یعنی یه صفحه cmd مخفی باز میکنه و بررسی میکنه که نصب هست یا نه. پس توی cmd تک تک ابزار موردنیاز رو بررسی کنید و اگه مشکلی نبود وینوس هم توی شناسایی اونا مشکلی نخواهد داشت.

3. Cordova
برای نصب کوردوا 2 راه دارید. یا فایل نصب اون رو از سایت وینوس بردارید که در لینک زیر قرار میدم. یا اینکه کد زیر رو توی cmd اجرا کنید.


کد:
npm install -g [email protected]

در صورتی که از کد بالا برای نصب استفاده می کنید باید به اینترنت متصل باشید تا چیزی حدود 60مگابایت دانلود شود.

بعضی از دوستان گفتن که چرا از نسخه 8 کوردوا توی وینوس استفاده نشده. نسخه 8 کوردوا برای خروجی گرفتن به اینترنت و یک فیل*ترشک*ن نیاز داره. من تا به الان نتونستم با نسخه 8 کوردوا خروجی بگیرم و به محض اینکه بتونم خروجی خوب و بی دردسری بگیرم توی وینوس قرار میدم.

بعد از نصب کوردوا (با هر یک از روش های بالا) کد زیر رو توی cmd اجرا کنید تا از صحت نصب اون مطلع بشید:
کد:
cordova -v

اگه بعد از نصب نسخه 6.5.0 کوردوا و اجرای کد بالا باز هم خطایی مبنی بر نصب نبودن کوردوا دریافت کردید مراحل زیر رو دنبال کنید:

  1. پنجره Run رو باز کنید. (با زدن همزمان کلیدهای پنجره+R کیبورد)
  2. عبارت %appdata% رو توی اون بنویسید و اجرا کنید.
  3. توی پوشه ای که باز میشه به دنبال پوشه ای به اسم npm بگردید و اونو پاک کنید.
  4. مراحل نصب کوردوا رو دوباره انجام بدید.
 
پاسخ دهید
 سپاس شده توسط: Mehrdad ، shazde ، ghasem ، hamid5700 ، mehrdad.ch ، maadking ، mostafanastary ، keyhan ، mhc ، amin COD
#2
4. Sdk اندروید
مهمترین ابزار برای خروجی اندروید. بدون این ابزار امکان خروجی اندروید گرفتن وجود نداره. توی هر انجین یا برنامه ای که خروجی اندروید میده لازمه که sdk نصب باشه تا بتونید خروجی اندروید بگیرید.

کلی راهنمای نصب به زبان های مختلف توی سایت های مختلف برای اون وجود داره.

فایل نصب sdk رو میتونید از اینجا دریافت کنید.
توصیه میکنم اونو توی درایوی غیر از درایو ویندوز نصب کنید تا اگه ویندوز عوض کردید sdk حذف نشه.

اگه اینترنت سریع و حجم زیادی دارید! میتونید کل sdk موردنیاز رو یکجا از اینجا دریافت کنید. (حجم فایل 4.90 گیگابایت)

اگه نمیتونید فایل بالا رو دانلود کنید ابزار زیر رو حتما نصب کنید:
  • Android support repository
  • Google play services
  • Api 14 Platform
  • Api 15 Platform
  • Api 19 Platform
  • Api 23 Platform
  • Api 25 Platform
  • Build Tools 19
  • Build Tools 23
  • Build Tools 25
راهنمای نصب sdk توی صفحه زیر توضیح داده شده:


این ابزار نصبش یکم دردسر داره بخاطر اینکه فیل*تر هستش و باید قسمتاش رو جدا جدا دانلود کنید و به محل نصب sdk در جای مناسبشون منتقل کنید. اما اگه فی*لترش*کن خوبی داشته باشید میتونید با اجرای sdk قسمتایی که میخواد رو تیک بزنید و نصب کنید:
[عکس: android-sdk.jpg]

همه قسمتای توی عکس لازم نیستند و فقط قسمتایی که در بالا گفتم لازمن.

کی قسمتای دیگه لازم میشن؟
توی عکس زیر که مربوط به تنظیمات پروژه وینوس شما هست قسمت sdk هدف رو مشاهده کنید:
[عکس: project_settings.png]

وقتی sdk هدف روی 23 باشه شما باید Api 23 Platform  رو توی sdk خودتون نصب شده داشته باشید. هر چقدر این مقدار رو بیارید پایین تر نسخه اندرویدی که از خروجی شما پشتیبانی میکنه کمتر میشه و هر چقدر بیشتر باشه دستگاه های با نسخه اندروید بالاتر رو پشتیبانی میکنه.

بعضی از پلاگین های اندروید پلتفرم خاصی رو نیاز دارن که نصب باشه. در صورتی که هنگام خروجی گرفتن توی وینوس با خطای sdk مواجه شدید ببینید کدوم پلتفرم رو لازم داره اونو نصب کنید.

یک نمونه از خطاهایی که دوستان ارسال کردن:
کد:
* What went wrong:
A problem occurred evaluating root project 'android'.
> No installed build tools found. Install the Android build tools version 19.1.0 or higher.

خیلی واضح داره میگه مشکل از کجاست ولی دوستان باز میان خطا رو ارسال میکنن!
داره میگه که build tools نسخه 19.1.0 نصب نیست. شاید شما نسخه بالاتر اون رو نصب کرده باشید. اما همونطور که قبلا گفتم ممکنه پلاگینی باشه که دقیقا همین نسخه رو میخواد. شاید این پلاگین خود کانواس پلاس وینوس هم باشه تست نکردم.

بقیه خطاهای مربوط به sdk هم به همین صورت هستن.
 
پاسخ دهید
 سپاس شده توسط: Mehrdad ، _mohammad_javad_ ، shazde ، ghasem ، hamid5700 ، mhammadahdi ، mostafanastary ، keyhan ، mhc ، amin COD ، hesam3 ، mdjd ، Amirreza-Yousefi
  


موضوعات مشابه ...
موضوع نویسنده پاسخ بازدید آخرین ارسال
Star مهم آموزش خروجی اندروید روی سیستم شخصی rezamms 110 2,535 1398/6/26، 12:41 صبح
آخرین ارسال: hesam3
  مهم کاربرد اکسپرشن ها محمد 82 20 456 1398/6/5، 04:42 عصر
آخرین ارسال: _mohammad_javad_
  دوره اموزش html5 wof team 3 158 1398/5/19، 11:33 عصر
آخرین ارسال: hesam3
  نظر سنجی ساخت اموزش هاست و onstorg مهدی بابایی 16 883 1398/5/18، 04:59 عصر
آخرین ارسال: مهدی بابایی
  پکیج ویژه وینوس + آموزش تصویری construct2j.blog.ir 48 3,113 1398/5/17، 02:53 صبح
آخرین ارسال: construct2j.blog.ir

پرش به انجمن: